Firefox 3 is great, but a few of my "required" extensions still haven't been updated for this yet-to-be-released version. One of which, Remove It Permanently, is essential for dealing with badly laid out websites.

Well it turns out that in that case, it's just a matter of:

  1. unpacking the XPI file (it's a renamed ZIP file) and
  2. bumping the "maxVersion" in the install.rdf file.

Update: Remove It Permanently 1.0.6.4 was released on 13 June 2008 and is compatible with Firefox 3.

Its one of my must haves too. It was quite annoying that it wasn't out when ff3 came out, but its there now. I find that they don't always show up in the update dialogue but if you search for them you can often find something to install.
Comment by Don